Intermittent Calling Issues - Cloud2Me Telephone Service
Incident Report for Cloud2Me Status Page
Resolved
The issue with our phone system has now been resolved.

Thank you for your patience.
Posted Oct 05, 2022 - 15:18 UTC
Identified
Our third-party phone provider has identified an issue that is currently affecting inbound calls to our main number, 01737 304 210.

This results in a delay for the caller getting connected to a member of our team.

If you have issues trying to reach us via phone, please feel reach to reach us via the usual support@cloud2me.co.uk email address, which will come directly through to our service desk.

We'll update this page as soon as we have further information. Thank you for your patience.
Posted Oct 05, 2022 - 11:21 UTC
This incident affected: Cloud2Me Support Service (Telephone Support).