Microsoft Online Services
Incident Report for Cloud2Me Status Page
Resolved
All services look to have returned to normal operation this morning. If you have any queries relating to your Microsoft online services, drop us a support case via the ordinary channels.
Posted Mar 16, 2021 - 13:11 UTC
Monitoring
Microsoft have recovered the majority of their online services, however any services dependant on Azure Active Directory may still be experiencing issues.

Further details can be located at https://status.office365.com/ .
Posted Mar 16, 2021 - 08:28 UTC
Investigating
Microsoft is currently investigating issues impacting their Office 365 and Azure services. Sub services such as Exchange email and Teams are of those affected by the issues.

You can follow their progress on the issues here; https://status.office365.com/ .
Posted Mar 15, 2021 - 20:51 UTC
This incident affected: Microsoft Online Services.