Issues receiving Telephone Calls

Incident Report for Cloud2Me Status Page

Resolved

This is now resolved and support calls are operational again.
Posted Jan 10, 2025 - 11:35 UTC

Update

We are continuing to investigate this issue.
Posted Jan 10, 2025 - 10:53 UTC

Investigating

We are currently experiencing issues receiving support calls. If you are trying to contact us for support, please email us at support@cloud2me.co.uk.

For urgent matters, please call 07309024923 or 07577573013. We kindly ask that you reserve calling for urgent issues only.

We will update this post as soon as we have more information.
Posted Jan 10, 2025 - 10:36 UTC
This incident affected: Cloud2Me Support Service (Telephone Support).