Inconsistent Service Connectivity (Performance)
Incident Report for Cloud2Me Status Page
Resolved
This incident has been resolved.
Posted Nov 16, 2022 - 22:10 UTC
Identified
We've been made aware of a handful of customers, struggling with their service speed. This is an issue caused by BT and some associated internet routing gremlins, which they are experiencing nationwide (see https://downdetector.co.uk/status/bt-british-telecom/ ).

Fortunately we have multiple internet circuits at our data centres and so are not affected ourselves. However your internet circuit (office / home) might well be, if you're using a BT based internet line.

We believe BT are working on the difficulties and hope to see the issues resolved soon. If you have any associated queries, please contact us via the usual channels.
Posted Nov 16, 2022 - 15:32 UTC
This incident affected: Hosted Desktop Services (Hosted Desktop - RDS, Hosted Desktop - Citrix), Data Centres (South London, Reading, Maidenhead, Gatwick), and Cloud4VC.