Cloud2Me - Phone system
Incident Report for Cloud2Me Status Page
Resolved
This incident is now resolved. PSTN calls inbound and outbound are now connecting successfully, and inbound calls are being received as expected.

We apologise for any inconvenience that this may have caused and the impact this may have had to your business, should you still be experiencing any issues please do not hesitate to contact us and we will investigate further.
Posted Apr 14, 2021 - 10:05 UTC
Update
This incident is now resolved. PSTN calls inbound and outbound are now connecting successfully, and inbound calls are being received as expected.

We apologise for any inconvenience that this may have caused and the impact this may have had to your business, should you still be experiencing any issues please do not hesitate to contact us and we will investigate further.
Posted Apr 14, 2021 - 10:03 UTC
Investigating
The Cloud2Me phone system is currently experiencing an issue where 50% of inbound calls are not connecting. We have tested this internally and all test calls are working but we are awaiting an update from our provider to confirm resolution of the issue.

If you are unable to contact us on our support line and you need to raise an incident please email us at support@cloud2me.co.uk with details of the issue and your best contact details and our engineers will call you back.

Next Update - 11am or as information comes available
Posted Apr 14, 2021 - 08:43 UTC
This incident affected: Cloud2Me Support Service (Telephone Support).