Cloud2Me Telephony Support
Incident Report for Cloud2Me Status Page
Resolved
Our telephone systems have remained stable since 14:00. Thank you for your patience while our provider worked on the issue.
Posted Mar 25, 2020 - 18:32 UTC
Monitoring
Normal service to our telephony systems has returned, we're now just ensuring it remains stable.
Posted Mar 25, 2020 - 14:04 UTC
Identified
Our 3rd party telephony company have identified an issue and are currently seeking a solution.
Posted Mar 25, 2020 - 12:50 UTC
Investigating
We are currently experiencing technical difficulties with our external telephony provider. If you require telephone support, please contact on either;

07597 572897
07577 573013
07590 319700
07309 024923

Please be advised that email support (Zendesk) is still fully operational.
Posted Mar 25, 2020 - 12:24 UTC
This incident affected: Cloud2Me Support Service (Telephone Support).