Intermittent Email Issues
Incident Report for Cloud2Me Status Page
Resolved
This issue has now been identified and resolved. Apologies for any inconvenience caused.

If you experience any further issues, please contact us on 01737 304211 or support@cloud2me.co.uk.
Posted Aug 25, 2021 - 19:22 UTC
Monitoring
We have stabilised the email anomaly and currently identifying the cause.
Posted Aug 25, 2021 - 17:00 UTC
Investigating
We're currently investigating an intermittent email issue on our "HEX2" platform, we shall update again shortly.
Posted Aug 25, 2021 - 16:12 UTC
This incident affected: Hosted Exchange Email Services (Hosted Exchange Email - HEX2).