Cloud2Me - Telephone Support
Incident Report for Cloud2Me Status Page
Resolved
Our helpdesk telephony is now back to business as usual. Apologies for any inconvenience.
Posted Oct 15, 2020 - 12:58 UTC
Monitoring
Power to our offices have been restored (for now!). Phones back to normal.
Posted Oct 15, 2020 - 11:32 UTC
Update
We are continuing to investigate this issue.
Posted Oct 15, 2020 - 11:14 UTC
Investigating
We have experienced a power cut in our main office. Support staff are online however our telephones are suffering slightly. If you can't get through to us, please raise a support case to communicate via email.
Posted Oct 15, 2020 - 10:52 UTC
This incident affected: Cloud2Me Support Service (Telephone Support).