Intermittent Service Connectivity
Incident Report for Cloud2Me Status Page
Resolved
We're pleased to confirm that we haven't observed any further connectivity issues, since this morning. Thank you for your patience and if you experience any related issues, please contact us via the usual channels.
Posted Feb 23, 2023 - 15:12 UTC
Monitoring
Our domain registrar has resolved their issues and we're not seeing any continued problems. We'll continue to monitor, until late PM.
Posted Feb 23, 2023 - 12:19 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 23, 2023 - 11:18 UTC
Identified
We've identified an issue with one of our internet domain registrars, having service issues themselves. We're putting in place measures to mitigate this issue, plus our domain registrar is working to resolve the issue.

As a consequence of this issue, you might experience difficulty connecting to your services with us. Please reattempt connection every 5 minutes, as the chances are that you'll soon get connected (and once connected, you'll be fine thereafter).

If you're really struggling to get connected, please do raise a support case with us, via the usual channels.
Posted Feb 23, 2023 - 11:18 UTC
This incident affected: Hosted Desktop Services (Hosted Desktop - Citrix) and Cloud4VC.