Intermitten Network Connectivity at Maidenhead Data Centre

Incident Report for Cloud2Me Status Page

Resolved

This incident has been resolved.
Posted Oct 23, 2024 - 17:13 UTC

Monitoring

Dear All, we were alerted to network connectivity issues at our Maidenhead data centre, at 13:15 today. Symptoms of this, would have been virtual desktop disconnections, along with slow performance and poor web browsing.

We suspected this to be a partially crashed, piece of critical network equipment, which we mitigated at approximately 14:05. From 14:05 we observed network connectivity return to normal and have been closely monitoring since, for any further issues.

If any customers reported issues into us, we'll have already called back or shall be doing so very shortly. Of course if anyone is still experiencing issues, please report these into our service desk.
Posted Oct 23, 2024 - 13:49 UTC
This incident affected: Hosted Desktop Services (Hosted Desktop - RDS, Hosted Desktop - Citrix), Data Centres (Maidenhead), and Managed Servers - Maidenhead.