Microsoft 365 Telephony Services (Teams Calling) - Service Issues
Incident Report for Cloud2Me Status Page
Resolved
Microsoft look to have cleared the issues and we're observing, that all services have now returned to normal.
Posted Mar 28, 2024 - 13:11 UTC
Investigating
Microsoft 365 currently has issues with their Microsoft Teams telephony component. This is affecting customers at least across the UK.

Consequently your Teams Calling services might be suffering (making/receiving calls). Also the Cloud2Me helpdesk is suffering, given we operate Teams Calling (but you can still contact us via email support).

We shall monitor the situation and update again shortly.
Posted Mar 28, 2024 - 12:23 UTC
This incident affected: Cloud2Me Support Service (Telephone Support) and Microsoft Online Services.