Apologies for any inconvenience caused and if anyone has any remaining issues, please get in touch with our Support Team.
Posted Nov 18, 2025 - 11:52 UTC
Monitoring
A quick update from us, that our troubled internet link has now been up and stable since 9:40 AM.
If anyone is experiencing any remaining issues, by all means please get in contact with us via the usual channels.
Cloud2Me Team
Posted Nov 18, 2025 - 09:57 UTC
Identified
We're are aware of connectivity issues affecting some customers, located at our Maidenhead and Redhill data centres. This is due to one of our 3rd party connectivity partners experiencing an issue themselves, for which they are busy repairing.
You might experience difficulty connecting to your Citrix session - if this is the case please contact us where we can assist you to work around this issue. You might also find that your printers are not working, as your site to site VPN connection is affected.
If you are experiencing any of these difficulties, please contact us via the usual support channels. We're hopeful that our connectivity partner will soon have their problem resolved.
Thank you for your patience. Cloud2Me Team
Posted Nov 18, 2025 - 09:34 UTC
This incident affected: Hosted Desktop Services (Hosted Desktop - Citrix) and Data Centres (Maidenhead, Redhill).