Sending Outbound Email - ProofPoint Delivery Notification
Incident Report for Cloud2Me Status Page
Resolved
This issue has now been resolved and in total there was a 10 minutes window where people sending email, would have received a bounce back.
Any blocked email will get automatically resent on your behalf.

If you have any further queries relating to this, please contact our service desk via the usual channels.
Posted Oct 20, 2020 - 12:48 UTC
Identified
We have been let down again by our email security filtering provider, ProofPoint. For a brief period you might have received a bounce back message immediately after sending an email.

We have put in place a work around to this issue now, therefore you should be able to use email as normal.

Any emails that got blocked when sending, shall shortly be resent for you automatically.
Posted Oct 20, 2020 - 12:28 UTC
This incident affected: Hosted Exchange Email Services (Hosted Exchange Email - HEX2, Hosted Exchange Email - HEX3).