Virgin Media Internet Problems
Incident Report for Cloud2Me Status Page
Resolved
We've observed Virgin Media remain stable so far today, therefore believe this issue to now be resolved.
Posted Apr 05, 2023 - 09:10 UTC
Monitoring
We're aware that some customers have been struggling to reach their Hosted Services today. Unfortunately this appears to be a prolonged issue with Virgin Media, whereby they had issues early this morning, only to have them return this afternoon.

We're observing that customers that do not directly use Virgin Media for their internet, are still seeing their internet services fail. This is likely due to the shared infrastructure for which Virgin power within the UK's internet network, but also the re routing of internet services, for those ISPs that remain online.

Do please keep track of the incident on Down Detector, seen here https://downdetector.co.uk/status/virgin-media/ . We're hopeful that they'll have the issues resolved for tomorrow.
Posted Apr 04, 2023 - 17:47 UTC
This incident affected: Hosted Desktop Services (Hosted Desktop - RDS, Hosted Desktop - Citrix) and Cloud4VC.