Intermittent Service Issues - Office 365 Email Connectivity
Incident Report for Cloud2Me Status Page
Resolved
Dear All,

Microsoft has now resolved the issues with Office 365 email connectivity since our previous update, and we have had confirmation that everything is now back online and working as normal via their status page (https://portal.office.com/servicestatus).

We are therefore going to close down this incident and we thank you for your patience and understanding throughout.

If anyone is still experiencing any issues, please feel free to contact us via the normal support channels.
Posted Jun 22, 2022 - 08:27 UTC
Identified
Microsoft has identified an issue with Exchange Online (365), whereby emails are being delayed whilst sending and receiving.

Consequently, some customers are experiencing degraded performance in Outlook, with emails arriving late or connectivity issues. Some users have also reported issues with accessing their mailboxes.

Please feel free to follow Microsoft's Service Status page for updates on the issue, https://portal.office.com/servicestatus.
We'll let you know once we have further information.
Posted Jun 21, 2022 - 11:45 UTC
This incident affected: Microsoft Online Services.